Jump to content


Video Embed Feature Eliminated!!???!!!

video embed

  • Please log in to reply
2 replies to this topic

#1 John

John

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 09 December 2013 - 02:18 PM

Although I've used the video embed feature a long time, I noticed for new emails it no longer actually embeds but instead redirects to the original video website.  Benchmark E-mail Support replied "...we have recently made some changes into our system and henceforth all the videos embedded in your Email will be played on the source website itself (instead of playing them within Email)."  In the same reply they described this change as a "system upgrade".

This is hardly an upgrade and is the PRIMARY reason I selected Benchmark E-mail over worthy competitors.  I could embed a picture of the video in a plain old vanilla e-mail and direct it to a video website, which would be amateurish!

Why? Why? WHY did you downgrade your capability to an amateurish presentation???????????  Pulleeeeezzzze return the true embed capability!

#2 benchmarkandy

benchmarkandy

    Advanced Member

  • Administrators
  • 166 posts

Posted 10 December 2013 - 04:28 PM

John,

I'm sorry you're displeased with the switch. I checked in with our support team and this was their response:

"The reason we started directing videos to their source website is due to SSL implementation.  Because of the embedded video code in the past, ISP's became suspicious and either chose to send those emails to the spam folder or reject them altogether.

With the recent upgrades (SSL),our system automatically attaches a link to the video, instead, ensuring better email deliverability."

Our R&D team is always working hard with an eye towards the future. This is currently the best solution with deliverability in mind, but I know they won't stop looking for a new best answer.

Best,

Andy

#3 J Doucet

J Doucet

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 January 2014 - 07:34 PM

Hey folks .... especially Support

I just signed on for a trial because I especially wanted video "not" to go to the source. After researching many similar service providers, I selected BenchMark because in one of the Tutorials it specifically stated that embed videos would not open at source (that training video dated 2012).

That was the primary reason for me deciding to trial Benchmark.

I am at this Forum because I attempted a couple of test emails and when the videos did open at source I thought I must be doing something wrong. It appears the video tutorial is outdated.

Is  there a work-around? For example, is there consideration for users to upload videos directly to a Benchmark video library (much like the Image library)? With the video content hosted there, that should appease the SSL argument.

In closing, here is my conclusion...

There are many email marketing service providers whom I would consider very close if not better in some respects than BenchMark. The distinguishing feature for deciding on Benchmark was the video integration. As mentioned in the original thread, anyone can put an image as a place holder and link it to the video source.

John/Support - please let me know if the current situation with how video is being handled will be staying. That's your real value add (or maybe it was).

J Doucet




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users